GAISE Workshop
Session 3
Nov. 8, 2005
3:30 – 5:30 pm

Brian Smith

Using technology for developing concepts and analyzing data
Uses of Technology

- **Super calculator/Number cruncer**
  - In this mode the use of technology allows the student to move from solving problems with small samples to analyzing large, realistic data sets.
  - Low level of conceptual understanding.

- **Grapher**
  - Assists in visualization of data, exploration of concepts of central tendency and variability, shape of distribution (symmetric? unimodal? normal?)
  - Medium level of conceptual understanding

- **Interactive Explorer**
  - Integrates numerical measures and graphs into an interactive package that permits exploration, visualization, and active learning.
  - High level of conceptual understanding

In this session we will investigate five technologies:

1) Excel
2) Minitab
3) Fathom
4) TI-83/84
5) Java Applets

A brief word about the advantages and limitations of each technology:

**Excel** is a superb number cruncer but its statistical capabilities are limited. Doubt has been cast on its random number generator for large scale commercial and scientific applications, but it is adequate for educational purposes. Several add-ins that add extra statistical features and improve user interface are available, and are often included with text books. Major disadvantage in the classroom is that many statistical procedures are not supported and it takes time and effort to program one’s own applications.

**Minitab** is a true statistical package with a large number of built-in statistical procedures. Many applications that are very limited in Excel are automatically available in Minitab, and in particular the ability to generate graphs to accompany procedures is useful. Solves large scale problems easily, has an intuitive Windows based user-friendly interface, and a relatively short learning curve. It also has the advantage that it is a serious statistical package that can be used for commercial applications as well as being an effective educational tool.
**Fathom** is an original and highly effective package for interactive exploration. It is an educational, pedagogical package and encourages independent investigation of the relationships between variables. It includes a superb collection of real data, including U.S. census data, for use by students, and also incorporates a number of useful interactive demonstrations that can be employed by the instructor for illustrating statistical concepts. Fathom’s interface is different from the point-and-click environment that we have come to expect from the Window’s based applications, but when you get used to it, Fathom is easy to use and requires little time and effort for the instructor who wishes to demonstrate statistical concepts.

**The TI-83/84** has the major advantage of being inexpensive and portable – essentially it puts major computing power into the hands of every student. Numerical output and graphical are limited by the screen size and the quality of the graphics, but nevertheless the universality of the calculators makes them a useful and effective tool for both numerical computation and graphical explorations.

**Applets** are small applications that are intended to demonstrate one concept e.g. Central Limit Theorem. There are many applets online and the user should carefully check them out before using them in class – they are not all of uniform quality. But there are some sites which are highly reliable and have effective applets. It is often useful to pause for a few minutes in a class to pull up an applet to illustrate a particular concept – and then tell students to continue to explore the applet, and the underlying concept, in out-of-class time.
Excel

The following data, obtained from the DASL website, shows long jump records for the Olympic games from 1900 (Year = 0) to 1984 (Year = 84).

<table>
<thead>
<tr>
<th>Year</th>
<th>Long jump</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>282.88</td>
</tr>
<tr>
<td>4</td>
<td>289.00</td>
</tr>
<tr>
<td>8</td>
<td>294.50</td>
</tr>
<tr>
<td>12</td>
<td>299.25</td>
</tr>
<tr>
<td>20</td>
<td>281.50</td>
</tr>
<tr>
<td>24</td>
<td>293.13</td>
</tr>
<tr>
<td>28</td>
<td>304.75</td>
</tr>
<tr>
<td>32</td>
<td>300.75</td>
</tr>
<tr>
<td>36</td>
<td>317.31</td>
</tr>
<tr>
<td>48</td>
<td>308.00</td>
</tr>
<tr>
<td>52</td>
<td>298.00</td>
</tr>
<tr>
<td>56</td>
<td>308.25</td>
</tr>
<tr>
<td>60</td>
<td>319.75</td>
</tr>
<tr>
<td>64</td>
<td>317.75</td>
</tr>
<tr>
<td>68</td>
<td>350.50</td>
</tr>
<tr>
<td>72</td>
<td>324.50</td>
</tr>
<tr>
<td>76</td>
<td>328.50</td>
</tr>
<tr>
<td>80</td>
<td>336.25</td>
</tr>
<tr>
<td>84</td>
<td>336.25</td>
</tr>
</tbody>
</table>

Level 1 use of Excel: supercalculator

To perform a Simple Linear Regression in Excel:

Click on Tools  Data Analysis
Select Regression from the menu

Complete the dialog box (be sure to check the “labels” box!):

Click on OK to obtain the following output:
SUMMARY OUTPUT

Regression Statistics

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple R</td>
<td>0.8703</td>
</tr>
<tr>
<td>R Square</td>
<td>0.7575</td>
</tr>
<tr>
<td>Adjusted R Square</td>
<td>0.7432</td>
</tr>
<tr>
<td>Standard Error</td>
<td>9.7568</td>
</tr>
<tr>
<td>Observations</td>
<td>19</td>
</tr>
</tbody>
</table>

ANOVA

<table>
<thead>
<tr>
<th></th>
<th>df</th>
<th>SS</th>
<th>MS</th>
<th>F</th>
<th>Significance F</th>
</tr>
</thead>
<tbody>
<tr>
<td>Regression</td>
<td>1</td>
<td>5054.89</td>
<td>5054.89</td>
<td>53.10</td>
<td>1.2700E-06</td>
</tr>
<tr>
<td>Residual</td>
<td>17</td>
<td>1618.33</td>
<td>95.20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td>18</td>
<td>6673.22</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Coefficients

<table>
<thead>
<tr>
<th></th>
<th>Standard Error</th>
<th>t Stat</th>
<th>P-value</th>
<th>Lower 95%</th>
<th>Upper 95%</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intercept</td>
<td>283.45</td>
<td>4.28</td>
<td>66.22</td>
<td>0.00000000</td>
<td>274.42</td>
</tr>
<tr>
<td>Year</td>
<td>0.6131</td>
<td>0.0841</td>
<td>7.2870</td>
<td>1.2700E-06</td>
<td>0.4356</td>
</tr>
</tbody>
</table>

The regression equation is \( \hat{Y} = \beta_0 + \beta_1 X = 283.45 + 0.6131X \).

We see that in the test of hypothesis \( H_0: \beta_1 = 0 \) the \( p \)-value is 1.2700E-06 (compare with TI-84) and we conclude \( \text{Reject } H_0 \), i.e. conclude that there is a linear relationship between length and year.

Further, we note that a 95% confidence interval for \( \beta_1 \) is \( 0.4356 \leq \beta_1 \leq 0.7906 \).

Level 2 use of Excel: grapher

Use the Chart Wizard feature to draw a scatter diagram and superimpose a linear regression on the diagram, specifying the linear regression equation and the \( R^2 \) value.
Level 3 use of Excel: Interactive

Explore the relationship between X and Y for the following data

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>24</td>
</tr>
<tr>
<td>1</td>
<td>26</td>
</tr>
<tr>
<td>2</td>
<td>35</td>
</tr>
<tr>
<td>2</td>
<td>33</td>
</tr>
<tr>
<td>3</td>
<td>57</td>
</tr>
<tr>
<td>3</td>
<td>60</td>
</tr>
<tr>
<td>4</td>
<td>55</td>
</tr>
<tr>
<td>4</td>
<td>51</td>
</tr>
<tr>
<td>5</td>
<td>43</td>
</tr>
<tr>
<td>5</td>
<td>41</td>
</tr>
</tbody>
</table>

Compare 4 different regression models:

- **Linear Regression**
  \[ y = 5.3x + 26.6 \]
  \[ R^2 = 0.3724 \]

- **Logarithmic Regression**
  \[ y = 15.746 \ln(x) + 27.423 \]
  \[ R^2 = 0.531 \]

- **Power Regression**
  \[ y = 26.825x^{0.03} \]
  \[ R^2 = 0.6341 \]

- **Polynomial (order 2 i.e. quadratic) Regression**
  \[ y = -5x^2 + 35.3x - 8.4 \]
  \[ R^2 = 0.8365 \]

Based on \( R^2 \) values the polynomial model is "best" insofar as it "explains" the highest percentage of variation in \( Y \).

Experiment: Change one of the Y-values in the table and see the effect on the four graphs! For example, change the first Y-value from 24 to 200.

Note: The graph is updated but the regression equations and \( R^2 \) values are not! It is necessary to delete these values and recompute.
Simulating the Central Limit Theorem in Excel

The Scenario

Consider a production process where the actual lengths of metal pipes produced vary uniformly between 19.5 and 20.5 cm. At regular intervals a random sample of five pipes is selected and the mean length is recorded. After 600 samples have been selected, the distribution of the sample means is plotted. Even though the population values are uniformly distributed and the sample size is small, we see that the distribution of sample means is approximately normal.

The ability to produce plots and to regenerate them interactively is based on the fact that the Rand() function in Excel, which generates a random number from a uniform distribution between 0 and 1, is automatically renewed every time the recalculate key (F9) is pressed.

The formula \{=FREQUENCY(G3:G602,H2:H22)\} is used to create the histogram. Every time the F9 function key is pressed the two graphs are regenerated. It is a nice demonstration of the fact that while 600 values of the original variable (length of metal pipe) is uniformly distributed in the range 19.5 to 20.5, the means of 600 samples of 5 metal pipes is approximately normally distributed.
We will show how Minitab can be used to analyze the long jump data:

Notice that the Minitab screen is divided into a session window (top half) and the data window (lower half). The data window is basically a spreadsheet and data can be exchanged with Excel by cutting and pasting. The long jump data is already stored in the data window.

To perform a regression analysis select Stat > Regression > Regression as shown below:
Running the regression analysis and selecting the “Four in One” option from the Graphs menu, we get the following results:

Notice that this output includes not only the regression equation and the ANOVA table for the regression, but also four graphs which can be useful for testing regression assumptions (e.g. normal distribution of residuals, equal variances, etc.)

To generate a scatter diagram select Graph > Scatterplot

and choose the “With Regression” option from the dialog box above. The scatterplot appears below:
Repeating analysis we have already performed in Excel:

**Explore the relationship between X and Y for the following data**

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>24</td>
</tr>
<tr>
<td>1</td>
<td>26</td>
</tr>
<tr>
<td>2</td>
<td>35</td>
</tr>
<tr>
<td>2</td>
<td>33</td>
</tr>
<tr>
<td>3</td>
<td>57</td>
</tr>
<tr>
<td>3</td>
<td>60</td>
</tr>
<tr>
<td>4</td>
<td>55</td>
</tr>
<tr>
<td>4</td>
<td>51</td>
</tr>
<tr>
<td>5</td>
<td>43</td>
</tr>
<tr>
<td>5</td>
<td>41</td>
</tr>
</tbody>
</table>

Select *Stat > Regression > Fitted Line Plot.*
Select the Type of Regression Model from the screen below:
We can produce the following graphs:

![Graphs Produced Using Minitab](image)

These graphs are the same as the ones produced using Excel.

**Central Limit Theorem Simulation in Minitab**

Repeat the process of generating 600 samples of 5 random values uniformly distributed between 19.5 and 20.5.

Select *Calc > Random Data > Uniform*

Complete the following screen:
Next, graph one column of 600 values of the uniform distribution, and also graph the 600 values of the means of samples of size 5:

Select Graph > Histogram and complete the dialog box:

You will see the two graphs below:
Once again we see that the histogram of the original values is uniformly distributed while the mean values are approximately normally distributed.
The following screen shows three elements of a Fathom analysis for the long jump data:

(1) the collection
(2) the case table
(3) a graph (scatter plot with least squares regression line).
Each of the elements above can be dragged into the document.

The next screen shows (1) a confidence interval for the mean distance jumped and (2) a test of hypothesis for the correlation between distance and year.
Exercise: repeat the confidence interval and test of hypothesis with *Verbose* toggled off.

![Image of Fathom software interface]

**Exercise 1: Exploring Data**

We use the file BeverlyHills to explore the data graphically.

- Investigate various graphs and see the impact of selecting an observation on all open graphs and the inspector.
- Investigate a scatter diagram of Income on Age
- Restrict age range (filter) to 18 – 80.
- See impact of the filter on the regression line.
- Then try age range 18 - 55

File → Open → Sample Documents → Learning Starter Guides → BeverlyHills

![Image of Fathom software interface with BeverlyHills file open]

The screen displays two entities:
1. A “collection”  
2. A text box describing the collection

Each gold ball in the collection represents one case.

When the cursor is placed over the collection the status bar in the bottom left-hand corner of the screen indicates that the collection has 150 cases and 10 attributes (variables).

To explore the attributes double click the collection. You will see the Inspector screen as below:

By clicking on a gold ball in the collection you can inspect the attributes for that case in the Inspector. The screen below shows the attributes for the 2nd case in the collection. Note that it is necessary to resize the Inspector to see the full description of some of the attributes.

Click on the Comments tab and you will see the description of the data set. This is a good place to store documentation and notes about the data.

Close the Inspector by clicking its close box.

**For spreadsheet fans!**

Click on the collection to select it (you will see a border around it).

To create a Case Table (spreadsheet), choose Case Table from the Insert menu or drag a new Case Table into the document.
The **Case Table** can be enlarged by dragging on a bottom corner of the table.

To see the full table we close the text box, shrink the collection until it is “iconized” and enlarge the **Case Table** by dragging on a bottom corner of the table.
Creating a Graph

Insert a graph into the document by (1) clicking on **Insert → Graph** (2) pressing CTRL-G or (3) dragging a new graph into the document.

We will make a graph of the attribute **age**.

Drag the **age** attribute from the **Case Table** and drop it onto the horizontal axis of the graph, where you see the message “drop an attribute here”.

A Dot Plot of **age** will now be displayed.

This graph can be changed to a histogram by choosing Histogram from the popup menu as seen below:
Experiment with dragging other variables onto the horizontal axes of the graph e.g. sex (how many of the respondents are male? What percentage is female?), **marital** (what percentage is divorced? Never married?)

**Making a Summary Table**

Drag a **Summary Table** into the document. Drag the attribute **sex** onto the down-pointing arrow to obtain the first graph below. The second graph is generated by dragging the attribute **marital** onto the down arrow.

When showing a categorical variable the default display is the number of cases in each group.

Other statistics can be displayed by changing the formula. For example to display the proportion of cases in each category, double-click on the formula $S1 = \text{count}( )$ to open the formula editing box. You can then edit the formula to display the proportion.
Click on OK to close the formula editor and the following results are displayed:

<table>
<thead>
<tr>
<th>marital</th>
<th>Summary Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Div</td>
<td>0.1</td>
</tr>
<tr>
<td>Mar</td>
<td>0.35333333</td>
</tr>
<tr>
<td>Nev</td>
<td>0.44666667</td>
</tr>
<tr>
<td>Sep</td>
<td>0.013333333</td>
</tr>
<tr>
<td>Wid</td>
<td>0.086666667</td>
</tr>
</tbody>
</table>

Close the Summary Table and open a new one. Drag the attribute age to the down arrow to obtain the following table.

<table>
<thead>
<tr>
<th>Summary Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>age</td>
</tr>
<tr>
<td>42.106667</td>
</tr>
</tbody>
</table>

Note that for a numerical attribute the default display is the mean. We see that the mean age of the people surveyed is approximately years 42.

**Splitting a graph**

Drag a new graph into the document and drop the age attribute onto the horizontal axis. Change the graph to a histogram. Now drag the sex attribute onto the vertical axis. You will now see that the histogram of age has been split on the attribute sex.
We can now compare the distribution of age for male and female respondents.

**Graphing Two Continuous Numeric Attributes**

To create a graph of income vs age, drag the attribute income onto the vertical axes of the graph age is already on the horizontal axis.) The following scatter diagram will be displayed.

We note that the under 20 year olds have almost no income, the highest incomes are earned by people in the 40 – 60 age group, and incomes decrease for older people.
Now replace *income* on the vertical axis with *educode*. We will use the new graph to illustrate the concepts of **Outliers and Influential Observations**. A point which lies far from the line (and thus has a large residual value) is known as an *outlier*. Such points may represent erroneous data, or may indicate a poorly fitting regression line. If a point lies far from the other data in the horizontal direction, it is known as an *influential observation*. The reason for this distinction is that these points may have a significant impact on the slope of the regression line.

The next graph shows a scatter diagram of Educode on Age.

![Graph of Educode vs Age](image)

Note that the $r^2$ value is 0.16, implying that 16% of variation in Educode (Educational level) is explained by Age.

Now apply the filter *Age < 25* to produce the following graph:

![Graph of Educode vs Age (Age < 25)](image)

We see that in the age range 0 - 25 the $r^2$ value increases to $r^2 = 0.75$ (for obvious reasons!).

Notice that there is one “unusual” observation corresponding to a twenty year old male with an Educode of 1 (“no school completed”). He is working as a cook and earning $11,000. This observation is an outlier.

When this observation is removed we see that the $r^2$ value increases to 0.88.
Question: How would you write up a report on this data set? Would you include the outlier and report a coefficient of determination of 75%, or analyze the data set with the outlier removed, and include an exception report in your final statement?

**Contingency Tables (Cross Tabulation).**

To create a contingency table of two categorical variable we drag a **Summary Table** into the document and then drop one of the attributes onto the horizontal axis, and the other onto the vertical axis. For example, the following table shows a cross-tabulation of marital status by sex.

<table>
<thead>
<tr>
<th>BeverlyHills</th>
<th>Summary Table</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>marital</td>
</tr>
<tr>
<td></td>
<td>Div</td>
</tr>
<tr>
<td>sex</td>
<td></td>
</tr>
<tr>
<td>F</td>
<td>9</td>
</tr>
<tr>
<td>M</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Column Summary</td>
<td>15</td>
</tr>
</tbody>
</table>

This example has introduced the basics - but there is lots more!! It is worthwhile to linger over this example for a while and experiment with other graphs and tables. For example we may wish to explore box plots and Ntigrams (for which cases are grouped into bins of equal sample size). Remember when you draw graph you can see the number (percentage ) of observation in each category by moving the cursor to the specified class and looking at the values in the status bar. Observe the ability to rescale the axes by dragging.
Other things to explore

- Test hypothesis that mean age = 40
  o Toggle **Verbose** on and off
- Establish a 95% confidence interval for mean age
- Investigate a multiple regression of Income on Age and Educode
  o Change order of independent variables and see effect on $r^2$
TI-84 Plus SE

Press <Stat>

Press <Enter> and scroll to the right.

Long Jump data is stored in L3, Year is stored in L4

Press <Enter> and scroll to the right.

Press <Stat>, Select CALC
Select 4: LinReg(ax+b)

Press <Enter>

LinReg
y=ax+b
a=.6131
b=283.4556
r²=.7575
r=.8703
The regression equation is now stored in Var Y₁

```
Y₁ = 6131X + 283.4

556
Y₂ =
Y₃ =
Y₄ =
Y₅ =
Y₆ =
```

Press <GRAPH> to see the regression line:

To perform a test of hypothesis:

\[ H_0 : \beta = 0 \text{ vs } H_A : \beta \neq 0 \text{ or } H_0 : \beta = 0 \text{ vs } H_A : \beta = 0 \]

Press <STAT>, highlight TESTS, and scroll down to F:LinRegTTest…
Complete the screen as shown below:

```
LinRegTTest
Xlist:L4
Ylist:L3
Freq:1
B & p:≠ 0 < 0 > 0
RegEQ:Y2
```

Select Calculate and press <ENTER>

```
LinRegTTest
y=a+bx
B≠0 and p≠0
t=7.2870
p=1.2700E-6
df=17.0000
↓a=283.4556
```

We see that the computed t-value is 7.2870 and the p-value is 1.2700E−6, therefore we reject $H_0$ and conclude that there is a significant linear relationship between Y (Distance) and X (Year).
To construct a 95% confidence interval for \( \mu \) we select the test **G:LinRegTInt** and we get the following result:

\[
\text{LinRegTInt} \\
y=a+bx \\
(0.4356, 0.7906) \\
b=0.6131 \\
df=17.0000 \\
s=9.7565 \\
a=-283.4556
\]

The 95% confidence interval is \( 0.4356 \leq \mu \leq 0.7906 \)

**Demonstration of Central Limit Theorem**

**Program clt.83p**  

```
DEMONSTRATE CENTRAL LIMIT THEOREM 
SAMPLE SIZE=25
```
$\overline{x}$ is being sampled 99 times from the uniform distrib.
Sample Size = 25
Men = .5 Variance = .0833