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Homework 8: JUnit 
 
 
Name : ___________________________________________________ 

Student Number : ___________________________________________________ 

Laboratory Time : ___________________________________________________ 

 
 
Objectives 
 

• Create JUnit Test Cases in Eclipse 
• Create JUnit Test Suites in Eclipse 
• Run JUnit Test Cases and Suites in Eclipse 

 
Preamble 
 
JUnit is a unit-testing framework for Java. It provides a common and reusable structure that is 
required for developing automate and repeatable unit tests for Java classes. JUnit provides a 
base class called TestCase that can be extended to create series of tests for your classes, an 
assertion library that can be used to evaluate the results of the tests, and test drivers, both 
command line and GUI based, called TestRunner to run the test cases you create. 
 
The recent version of the Eclipse JDT already has JUnit Plug-in built in to make creating and 
running test cases more convenient. The plug-in includes a wizard for assisting in creating testing 
a test case and test suite, and an environment for running them. 
 
In this lab, you will learn how to set up a project for creating JUnit tests. Then you will create 
test cases and a test suite, and run them. 
 
 
Grading Checklist 
 
By the end of the laboratory session, you need to demonstrate to the TA that you can do the 
following tasks. The TA will check off the items below that you have completed and collect this 
cover page from you. 
 

 JUnit library is in the project’s build path 
 Test case for GUIEnvironment class has been created and asserts added to init 

method body 
 The test case for GUIEnvironment runs successfully (may find errors in 

GUIEnvironment) 
 Test case for Processor class has been created and assert added to calculate 

method body 
 The test case for Processor runs successfully (may find errors in Processor) 
 Test suite created and works 

 
 
TA Initials: ____ 
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Instructions for the Laboratory 
 
 
Task 1: Set up a new project and create JUnit Test Cases for the GUIEnvironment 
class 
 
For this task, you will set up a new project and include the provided classes in the project. Then 
you will create a test case to test the GUIEnvironment class. In JUnit convention, a test class is 
created for every application class, and every non-trivial method is tested. 

a) Download and uncompress LunarLanderHW8.zip, which contains GUIEnvironment.java 
and other Java files as in Homework2. 

b) Create a new Java project in Eclipse called inf111_JUnit. In a New Java Project diaglog, 
select the option to “Use project folders as root for sources and class files” 

 

 
 

c) Create a package for source code and unit test code. In this class, we adopt the 
convention to place the unit test source code in the same package as the code being 
tested. 

1. Import GUIEnvironment.java and other java files in the zip file into a default 
(unnamed) package. You can do this by right clicking on the project and then 
selecting Import → General → File System. You need to select the directory 
where you have Java files residing. You can use Eclipse's file filtering capabilities 
here. 

 
 

2. Create a new package and name it lunarLanderPackage (note the lowercase ‘l’) 
 
 
 
 



INF 111 / CSE 121 

  3/12 

 
 
3. Use the refactoring feature to move the java files from the default package into 

the lunarLanderPackage that you just created. 
 

 
d) Create a JUnit Test Case Class. 

1. First, to bring up the New JUnit Test Case Wizard, select the lunarLanderPackage 
package. Then, select File → New → JUnit Test Case. 

2. Name the class by putting the name GUIEnvironmentTest in the name test box. 
3. Select setUp() and tearDown() boxes to automatically generate skeleton of these 

methods. The setUp() and tearDown() methods are run before and after each 
test case is run. 

 

 
 

4. For "Class under test", enter GUIEnvironment. Eclipse should find 
GUIEnvironment class in the lunarLanderPackage and should select it (Browse..). 
Then press Next. 
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5. Now you can select methods for which test method stubs will be created. Select 
init(). 

6. Press Finish.  
7. A dialog should pop up to ask whether JUnit library should be added to the build 

path.  Select “Perform the following action:” and OK 

 
8. A new class, GUIEnvironmentTest, that extends junit.framework.TestCase is 

created with generated method stubs. 
 
 

e) Implement a test case function in GUIEnvironmentTest to test the GUIEnvironment class. 
1. In GUIEnvironmentTest, create a new class variable, lunarLanderEnvironment as 

a private variable of the type GUIEnvironment. 
GUIEnvironment lunarLanderEnvironment; 

 
2. Implement the setUp() method to initialize variables. 

lunarLanderEnvironment = new GUIEnvironment(); 
 
3. Implement the tearDown() method to clear the variable. 

lunarLanderEnvironment = null; 
 
4. Implement the testInit() to check that GUIEnvironment initialization method is 

working correctly. 
lunarLanderEnvironment.init(); 
assertFalse(lunarLanderEnvironment.getHit()); 
assertNotNull(lunarLanderEnvironment.getSpaceCraft()); 

 
5. Add in testInit() two assertions to validate that Clock and Sensor (properties of 
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GUIEnvironment) are not null. 
 
If you get a compilation error, be sure to import the required packages, including 
junit.framework.Assert package. 
 
You can find more information on the assert API in the JUnit JavaDocs at 
http://www.junit.org/junit/javadoc/3.8.1/index.htm 
 
 
Task 2: Running GUIEnvironmentTest as a JUnit test case 
 
In this task, you will run the test case in GUIEnvironmentTest as a JUnit Test Case. 
 

a) Right click at GUIEnvironmentTest, and select Run → JUnit Test. 
b) You should see the result of your test case in JUnit view. If the view does not appear, 

show the JUnit view by selecting Window → Show View → Other → Java → JUnit. 
 

 
 
 
Task 3: Create JUnit Test Case for the Processor class 
(You may want to skip this task if you are running behind on time) 
 

a) Now repeat Task 1, step d) to create a test case for the calculate method in the 
Processor class. Implement a test case function in ProcessorTest to test the Processor 
class. 

1. Create three new class variables, lunarLanderEnvironment as a private variable 
of the type GUIEnvironment, spaceCraft as a private variable of the type 
SpaceCraft and processor a private variable of the type Processor. 
GUIEnvironment lunarLanderEnvironment; 
SpaceCraft spaceCraft; 
Processor processor; 

 
2. Implement the setUp() method to initialize variables. 

processor = new Processor(); 
lunarLanderEnvironment = new GUIEnvironment(); 
lunarLanderEnvironment.init(); 
spaceCraft = lunarLanderEnvironment.getSpaceCraft(); 
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JFrame app = new JFrame(); 
app.setDefaultCloseOperation (JFrame.EXIT_ON_CLOSE); 
app.getContentPane().add (lunarLanderEnvironment); 
app.setSize (800,800); 
app.setBackground (Color.WHITE); 
app.setLocation (0,0); 
app.addKeyListener (lunarLanderEnvironment); 
app.setVisible (true); 

 
3. Implement the tearDown() method to clear the variable. 

lunarLanderEnvironment = null; 
spaceCraft = null; 
processor = null; 

 
4. Implement the testCalculate() to check that the calculate method is working 

correctly. 
int rotation; 
rotation = spaceCraft.getRotation(); 
//simulates right key pressed 
lunarLanderEnvironment.setKeyPressed(KeyEvent.VK_RIGHT
); 
processor.calculate(spaceCraft, 
lunarLanderEnvironment); 
assertEquals(rotation + spaceCraft.getRotationRate(), 
spaceCraft.getRotation()); 
 

5. Run ProcessorTest as a JUnit Test Case (See Task 2). 
 

 
If you get a compilation error, be sure to import the required packages, including 
junit.framework.Assert package. Other classes that are needed to be imported are 
java.awt.event.KeyEvent, java.awt.Color and javax.swing.JFrame class. 
 
 
Task 4: Creating a Test Case Suite 
 
In this task, you will create a test case suite for the test cases created in Task 1 and Task3. A 
test case suite allows more convenient test case execution and will allow you to run all your test 
cases at once. 

a) Create a Test Suite by selecting the lunarLanderPackage package, and then selecting 
File→ New → Other → Java → JUnit-> JUnit Test Suite. 
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b) In the next screen, name the Test Suite “LunarLanderAllTests”, and include your test 
cases created in the Task 1 and Task 3 (GUIEnvironmentTest and also ProcessorTest if 
you had time) into the test suite by selecting the check boxes in front of the appropriate 
classes. Then click Finish. 

c) Run the test suite by selecting the Test Suite class, and then Right Click → Run → JUnit 
Test 
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Appendix 

 
You can also manually add the JUnit library, junit.jar, to the project’s build path using the 
following steps. 
 

a) Right click the project and select Properties. The properties dialog box as shown below 
should appear. 

 

 
 

b) Select Java Build Path on the left panel and bring the Libraries tab forward. 
c) Click on “Add External JARs…” button. 
d) In the JAR Selection dialog box, find the plugins directory under Eclipse’s installation 

directory (C:\Opt\eclipse). Then locate the JUnit folder. The current version of JUnit 
should be org.junit_3.8.1. From that directory, select junit.jar, as in the figure below. 
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Testing (70 points) 
 
In this part of the homework, you will be finishing off the test suite for the DVDVendor code. 
Some test cases have been provided for you. There are three use cases at the end of this 
document that specify the expected behavior of the software. You should cover all the sub-
variations in your integration test cases. 
 
1. Unit Tests. (20 points) Create JUnit tests for the following classes: 

• BarCode.java 
• CheckOutCart.java 

 
Be sure to test with a variety of valid and invalid Barcodes (include null objects, different lengths, 
and test the checksum). As well, these tests should be in the same package as the application 
code. You can use the test class DVDTest.java as an example to implement your own unit tests. 
 
2. Integration Tests. (40 points) Create the following integration tests for the rent 
transaction in the DVDVendor system: 

• Adding DVDs 
• Dispensing DVDs 
• Notifying the DVD dispenser of dispense events 
• Sequences of adding, paying for, and dispensing DVDs 
• Renting large numbers of DVDs (at least 15) 

 
The first two tests can be added to the DVDVendorTest.java class in the integrationtest package. 
The remaining tests should be put in the same package using as many or as few additional 
classes as you desire. Include in your report the bugs or missing functionality that the test cases 
helped you to find. 
 
3. Test Suite. (5 points) Create a test suite so that all the tests will run automatically. You 
should include all the test cases that were provided and the unit and integration tests that you 
created. 
 
4. Commenting the Code. (5 points) Document your tests cases using informative, high-
quality comments in the code. You should explain what you are testing for and how you are 
going about doing so. Where appropriate, you should include Javadoc comments. 
 
Deliverables 
 
Your deliverables are your JUnit test cases and a written report describing your changes. Be sure 
to include a list of classes and methods that were changed or added, so the TA can examine your 
work. 
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Handing In Your Assignment 
 
Your assignment must be submitted electronically to checkmate.ics.uci.edu. You will submit two 
files. 

1. Your report in Report.doc or Report.pdf. The report should describe your changes to 
the code and any other information that you want the TA to know about. In other words, 
if you want credit for your work, you should describe it here. 
2. A zip file containing all of the application and test code for the DVDVendor system. 

Do not zip these two files into one big .zip file.  
 
Use Case Name Rent Transaction 
Scope DVDVendor system 
Level User-goal 
Primary Actor Customer 
Stakeholders 
and Interests 

Customer wants to rent DVDs. 
The owner of the DVDVendor wants DVDs to be rented and charge 
money for the DVDs. 
Credit card company wants to process credit card information to 
charge money. 

Preconditions User wants to rent one or more DVDs 
Success 
Guarantee 

User has chosen one or more DVDs, paid for them, and has physical 
possession of them. 

Main Success 
Scenario 

1. Per each item: 
1.1. User adds DVD. 
Include use case: Add DVD 

2. User pays for the DVDs rented. 
3. For each item: 

3.1. System notifies the device to dispense the DVD. 
3.2. System verifies that the dispensed DVD is in the rental 

transaction. If this is the last DVD in the transaction to be 
dispensed, the system will change its status to start another 
rent transaction. 

4. Record transaction. 
 

Extensions Alternate Branch. 
 
1.1  If the system is dispensing or processing payment, it will not 

allow to add the DVD and will throw an exception. 
2 If no items have been added, the system will not allow payment 

and will throw an exception. 
2 If the system is dispensing, it will not allow payment processing 

and will throw an exception. 
2 If there is any problem with the payment, the system will throw an 

exception. 
3.1  If the system is adding items, it will not allow the DVD to be 

dispensed and will throw an exception. 
3.2 If a DVD that is not in the rent transaction has been dispensed, 

the system will throw an exception. 
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4 If there is any problem recording the transaction, the system will 
throw an exception. 

 
Special 
Requirements 

 

Technology and 
Data Variations 
List 

DVD dispenser hardware, database 

Frequency The system expects 1 rent transaction placed every 10 minutes 
Miscellaneous  

 
Use Case Name Add DVD 
Scope DVDVendor system 
Level Subfunction 
Primary Actor Customer 
Stakeholders 
and Interests 

Customers want to add DVD so that they can rent them 

Preconditions User started the transaction 
Success 
Guarantee 

DVD is added to the transaction 

Main Success 
Scenario 

1. The system throws the DVDs (Barcode and title for each DVD). 
2. User selects a DVD. 
3. The system validates the Barcode. 
4. The system looks for the Barcode in the Database of products. 
5. The system verifies that the DVD has not already been added to 

the rent transaction. 
6. The system verifies that the DVD is available to be rented. This 

means that it has not been rented in another transaction. 
7. The system adds the item to the transaction. 
8. Add cost to total cost. 

Extensions Alternate Branch. 
3. If the value of Barcode is null, the system will throw an exception. 
3. If the Barcode does not have 12 digits, the system will throw an 

exception. 
3. If the checksum of Barcode is not valid, the system will throw an 

exception. 
4. If the DVD is not found in the Database, the system will throw an 

exception. 
5. If the DVD is already in the rent transaction, the system will throw 

an exception. 
6. If the DVD has already been rented in another transaction, the 
system will throw an exception. 
 

Special 
Requirements 

 

Technology and 
Data Variations 
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List 
Frequency The system expects an average of 2 DVDs added per rent 

transaction  
Miscellaneous  
 
 
 
 
 


