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Laboratory 4: Getting Started with CVS

Name

Student Number

Laboratory Time

Objectives

e Set up a CVS repository on UNIX
e Use Eclipse as a CVS client

Preamble

CVS is an acronym for Concurrent Versions System. It is a version control system and is used to
record the history of your source files. Bugs can creep in when software is modified, and may not
be detected until a long time after the modification is made. With CVS, you can retrieve old
versions to find which change caused the bug.

CVS can also help when a project is being worked on by multiple people, where overwriting each
others’ changes is easy to do. CVS solves this problem by having each developer work in his/her
own directory and then instructing CVS to merge the work when each developer is done.

In this laboratory, you will create a CVS repository on UNIX. You will then access this repository
from the Eclipse workbench. You will then have a “sandbox” or working copy of the files.

Grading Checklist

Configure UNIX Shell

Connect to CVS Repository from Eclipse
Check in a Project

Check out a Project

oooo

TA Initials:
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Instructions for the Laboratory

Task 1: Configure Your UNIX Shell

For this task, you will verify that CVS is available in your UNIX environment. If CVS is not available,
you will add it. CVS needs to be available so that you can create a CVS repository in your home
directory and connect to it using Eclipse in later tasks.

a) Log in to your UNIX account
1. Open SecureCRT 5.2

I Rational Software

@ SecureCRTS.2 [Z) HISTORY

»
»
I Sophos » I £] ORDER
I/ startup » || £] README
I stata | & sSecureCRTS.2
) winCvs »

2. Select openlab.ics.uci.edu and click Connect. If a "New Host Key” window appears, click
the “Accept and Save” button. Then, it will show a “SecureCRT Window” indicating that
the “Access is denied”. Click “OK".

3. Enter your username and click “OK". Then, enter your password and click "OK". You will
see the Unix prompt.

Enter Secure Shell Password @

rgallard@openlab.ics.uci.edu requires a password.

Please enter a password now.
Cancel

Username: ’lgallard

Password: [|

[l save password

b) Type in the command “module list”
This command will produce a list of modules, or packages of programs, that are available to you
in your UNIX environment. The output should look something like the following.

&= openlab.ics.uci.edu - SecureCRT

File Edit View Options Transfer Script Tools Help

o E A QR =8 FHY 2

‘ | openlab.ics.uci.edu

rgallard@rodan’ module list
Currently Loaded Modulefiles:

1) std-unix 6) tex/3,14159 11} emacs/20,4

2) openssh/d,1pl 7) res/B,7 12} g=su/3.0a

3) local 8) cde/l.4 13) ics—default

43 nmh/1,0.4 9) x11/6,3

5) tetex/1,0 10} public
rgallard@érodans i e
Ready ssh2: AES-256 24, 17 24 Rows, 80 Cols  ¥T100 NUM
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If the output includes CVS, as in item similar to “cvs/1.11.6", then you are done with this
task. Otherwise, go to step ¢).

c) Add the line “"module load cvs” to your .cshrc file (notice that there is a period at the
beginning of that file nhame). The following steps will show you how to do this change using
Text Pad. If you want to use a UNIX editor such as vi, you can use it.

1. Go to your H: drive using Windows Explorer and find the file .cshrc. Right click on it and
open it using Text Pad.

® rgallard on ‘data’ (H:)

File Edit View Favorites Tools Help
@ Back ~ < [y ’ ) search ‘ui Folders '
Address Lg Hi
Folders X Mame
() Templates ~ BrE open
# ) WINDOWS ) forr P
# |2) workspace hist Make Available OFfline
(22 rmurthy Jogi  Scan with Sophos Anti-Virus
[C3) RSCHEN M TextPad

2. You should add your line *module load cvs” close to the other module load commands
in the .cshrc file.

< TextPad - [H:\.cshrc *] Q@@

% File Edit Search View Tools Macros Configure MWindow Help -8 X
el 8ERkB =) EE 29 QU LHE BCH| . K2
Alx

—

cshrc * Add the basic modules. This line will automatically get updated o

when you run the "module initadd" or "module initrm" commands

ics—-default: Contains essential programs including the local programs
and the Department-supported windowing system.

WU Provides access to WWW utilities such as netscape

sun-lang: Provides access to the Sun compilers under Solaris

HuEBRERBE R R

nodule lo ics—default

module lo;d cvs

3. Make sure you save the file as a UNIX FILE FORMAT. Go to the Save As.. option and
indicate: Save as Type: All Files (*.*) and File format: UNIX. If you are asked if you
want to replace the file, click “Yes.”

File hame: [.cshrc v } I Save I
Savesstpe AT | [_Coce

File format: UNIX v

Encoding: ’ ANS| v ‘

d) Log out from SecureCRT using the “exit” command and repeat steps (a) and (b) to verify
that the edit was completed correctly. You should see the cvs/1.11.6 module listed.
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&= openlab.ics.uci.edu - SecureCRT

File Edit Yiew Options Transfer Script Tools Help

o HEH QA= &% 2

‘l openlab.ics.uci.edu

rgallard@mothra% module list
Currently Loaded Modulefiles:

1) std-unix 6) tex/3,14159 11} emacs/20.4

2} openssh/d,1pl 7) rcsd/B5.7 12} 2su/3.0a

3} local 8) cde/l.4 default

4> ruh/1,0.4 9) x11/6.3 w

5) tetex/1,0 10} public

rgallardé@mothra¥ ™
|Ready ssh2: AES-256 24, 18 24 Rows, 80 Cols  ¥T100 MUM
If you want to know more about how modules work,

http://www.ics.uci.edu/computing/unix/modules/

Task 2: Add a Directory for Your CVS Repository
This task involves creating a directory for your CVS repository in your UNIX Account.

a) Log in to your UNIX account.

visit

b) Create a directory called “111-repository” (or 121-repository, if you prefer). The command
to do this is “mkdir 111-repository”. Do not place the directory in a subdirectory

within your account.

¢) Change to this directory. To do this, use the command "cd 111-repository”

d) Take note of the full path to this directory. Type the command “pwd” and write down the

result.

e) Initialize the CVS repository: Type in the command “cvs —d <path> init”. Be sure to

substitute the string that you wrote down in step (d) instead of <path>.

&= openlab.ics. uci.edu - SecureCRT

File Edit Yiew Options Transfer Script Tools Help
HERIE RBRQ L& @HY 2

| openlab.ics.uci.edu

rgallard@mothra? mkdir 1ll-repository

rgallard@mothra? cd 1ll-repository

regallard@mothra? pud

/home/rgallard/111-repository

regallard@mothra? cvse -d /homesrgallard/11ll-repository init
rgallard@mothra ™

|Ready ssh2: AES-256 24, 18 24 Rows, 80 Cols  VT100 MNUM

Task 3: Connect to Your CVS Repository from Eclipse

a) In Eclipse, go to the CVS Perspective: Select Window -> Open Perspective -> Other -> CVS

Repository Exploring.
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b) Create a new Repository Location: In the CVS Repositories tab, right click and select New ->
Repository Location.

¢) Fill in the dialog box as indicated in the screen shot below. Then, click Finish.

€ Add CVS Repository 3]

[[]save password

Add a new CVS Repository
Add a new C¥S Repository to the CVS Repositories view

Validate connection on finish

1 Saved passwords are stored on your computer in a file that is difficult, but not
impossible, for an intruder to read.

|CVS
Location
Host: openlab.ics.uci.edu v Host: openlab.ics.uci.edu
Repository path: | fhomejrgallard/111-repository v Repository path: The result from Task 2. Step d)
Authentication A
ser: | rgallard 3 User: Your UNIX id )
Password: Leave this blank
Password:
Connection
Connection type: ‘ N Connection Q!De- extssh
(®) Use default port
O Use port:

[ Finish ][ Cancel ]

d) Connect using this new Repository Location

1.

If you have already connected securely to this host before, click on "Finish" and go
directly to step (4). Otherwise, just follow the steps (if you do not remember, just check
the steps and skip accordingly).

If this is your first time connecting securely to this host, once you click on "Finish" a
question box will appear asking if you accept the RSA fingerprint. Click "Yes".

Next you may be asked if you wish to create the known_hosts file to save the RSA
fingerprint into. Click "Yes".

Next you may be asked if you want to create the parent directory for ssh. Click “Yes”.
You will see a message indicating that the ssh directory has been successfully created.
Click “OK".

When using Eclipse it will try to Authenticate using publicKey, password, and keyboard-
interactive, in that order. PublicKey Authentication fails silently in the background, and
then we are presented with the Password Authentication dialogue box. Type your Unix
account password here and click "Ok".
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& Password Required @

\% Password for rgallard@openlab.ics.uci.edu

:extssh:rgallard@openlab.ics.uci.edu: fhomefraallardf111-rep

CVS Repository: G

User name: rgallard ‘
Password: eseseses| ‘
[[]5ave password

1, Saved passwords are stored on your computer in a file that is difficult,
but not impossible, for an intruder to read.

®

7. You will see the repository you just created:

EI CYS Repositories X CYS Annotate =
=[] iextssh:rgallard@openlab.ics.uci.edu: fhomejraallardf111-repository:

@R HEAD
[+ %‘R Branches
-5 Yersions

E@ Dates

For additional help on setting up a CVS repository, see the online help in Eclipse.

& Help - Eclipse SDK

Search: Sear

Contents

@] Workbench User Guide
=) [ Getting started
& [ Basic tutorial
= [ Team Cvs tutorial
B Setting up a CVS repository
2 starting offine
= [ Sharing the project
ecifying a repository location
[ Repository locations
[2 sharing a project
[ working with another user
[ working with CVS History
[ ant & external tools tutorial
[ concepts

Task 4: Check In a Project

a) Go to the Java Perspective: select Window -> Open Perspective -> Java. Go to the Package
Explorer.

b) Look for the project infl111_JUnit that we created in Laboratory 2. If the project from
Laboratory 2 is not listed in the Package Explorer, open the project from Laboratory 2. If
you do not have it, you can create a new project and a new class in this project, but please
let the TA know about this.

¢) Check in your project:

1. Right-click on the project (inf111_JUnit) and select the Team -> Share Project... menu
item.
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= example
=2 Helloworld
J

Mew

a=

i

-8 I

- | OpeninNew Window
) Open Type Hierarchy

B ]
lab1l =) Copy

' Paste
¥ Delete

Build Path
Source
Refactor

g Import...

23 Export...

P Refresh
Close Project

Close Unrelated Projects

Run As
Debug As

Team

Compare With

Dackava Fram | amal Hickavo

@ *
»

F4

Chrl+C

Chrl+y
Delete

>
Ale+sShift+5 ¥
Alt+Shift+T ¥

FS

»
»
»

»

Hierarchy JUnit| = O Helloworld.java &2 [ Gu

Creator: Your n:

package inf111;

ic class Hello
public static
System. out

}

s &2 . Javadoc | Dec
arnings, 0 infos

n

rnings (4 items)

The import java.awt.ge
The import java.awt.ge
The serializable class Gl

Apply Patch...

Share Project...

Select “use existing repository location” and click “Next”.

Select “use project name as module name” and click “Next”.
Click “Finish” to commit the files to the repository.
You will see a “Share Project Resources” window. Click “Finish”. If you are asked to

enter a comment for the commit, enter “First Commit” and click “Finish”.

You will see your project in the Package Explorer similar to the following screenshot:

=

=]

Task 5: Check Out a Project

a)
b)

£y img

= 1—5’- inf111_JUnit [openlab.ics.uci.edu]

Q] lunarlander.png 1.1 (Binary)

I lunarLanderPackage

@ [J] Clock.java 1.1 {(ASCII -kkv)

@R

—

#4114 GUIEnvironment.java 1.1 {ASCI
- [J] IObserver.java 1.1 (ASCII -kky'
- [J) ISubject.java 1.1 {(ASCII -kky)
@ [J] Observerll.java 1.1 (ASCII -kk
- [J) Processor.java 1.1 (ASCII -kkv)
@ [J] SpaceCraft.java 1.1 {(ASCII -kk:

B3 unitTests

B, JRE System Library [jre1.6.0_02]

B JUnit 3.8.1

Go to the CVS Repositories perspective
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Go to the Java Perspective: Select Window -> Open Perspective -> Package Explorer.

Check out the project you just committed (inf111_JUnit) from your CVS repository
1.
2. Select the “"Head” and expand it

Close the project you just committed (infl11_JUnit): Click on the project name and then
select Project -> Close Project.
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3. Select the project name (inf111_JUnit)
4. Right-click the project and select the “Check out” menu item (note: If you do not want

to overwrite your project in your workspace, select "Check out As..” menu item instead)
m CYS Repositories X CVS Annotate =

= [ :extssh:rgallard@openlab.ics.uci.edu: fhome/rgallard/11 1-repository
=N HEAD
#-(= CYSROOT
# 4R Branches Mew 4
oy
Check Out As...

v

A “Confirm Overwrite” dialog box will appear. Click “Ok”

6. Go to the Java Perspective (Window -> Open Perspective -> Java). Make a minor
change to the GUIEnvironment.java file: Change line 23 and 24: (If you are not using
inf111_JUnit you can make a minor change in the class you just created, such as adding
a comment).

Before changing:
int wRec=70;
int hRec=70;
After changing:
int wRec=80;
int hRec=80;
7. Save the file you changed (GUIEnvironment.java).

d) Check In the modified project and verify your changes

1. Select the project you are working on (inf111_JUnit).

2. Right-click on the project and select the Team ->Commit... menu item

3. A “Commit Files” dialog box will appear. Write a comment "I changed the value of wRec
and hRec properties” and click “Finish” (note that only the modified file is going to be
uploaded to the repository).

4. Go to the CVS Repositories perspective and select the project you are working on
(inf111_JUnit).

5. Right-click on the project and select “Refresh View”. Find the file you modified
(GUIEnvironment.java) and you will see the changes you made in this file. You will also
see that this file has the version 1.2 now.

rll CYS Repositories X CVS Annotate - GUIEn

= [ :extsshirgallard@openlab.ics.uci.edu: fhome
=R HEaD
#-(= CYSROOT
== inf111_JUnit
(= img
(= ( lunarLanderPackage
[3) Clock.java 1.1
o
] IObserver.java 1.1
[J) 15ubject.java 1.1
[J] oObserverLL.java 1.1
E} Processor.java 1.1
[4) SpaceCraft.java 1.1
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